Some users are experiencing problems accessing RDSF. Operational

Components

Research Data Storage Facility (RDSF)



May 10, 2018 9:09AM BST
[Investigating] We are currently investigating

May 10, 2018 11:11AM BST
[Resolved] The problems with RDSF should now be resolved. We apologise for any inconvenience whilst it was unavailable.

Back to current status