Research Data Storage Facility (RDSF)
June 21, 2017 10:42AM BST
[Investigating] There has been a power cut which has taken out BC2 and BC3. We are working to restore the systems.
June 21, 2017 11:31AM BST
[Resolved] Apologies for any inconvenience caused.